Curve2dGetClosestPointTo(Point2d,
Tolerance) Method
|
Retrieves the closest point on this curve to
the specified point within the specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve2d GetClosestPointTo(
Point2d point,
Tolerance tolerance
)
Public Function GetClosestPointTo (
point As Point2d,
tolerance As Tolerance
) As PointOnCurve2d
public:
PointOnCurve2d^ GetClosestPointTo(
Point2d point,
Tolerance tolerance
)
member GetClosestPointTo :
point : Point2d *
tolerance : Tolerance -> PointOnCurve2d
Parameters
- point Point2d
- [in] Point to which the closest point is calculated.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
PointOnCurve2d
The closest point on this curve.
See Also