RadialDimension(Point3d, Point3d, Double,
String, ObjectId) Constructor
|
Constructor. Creates a RadialDimension object
with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public RadialDimension(
Point3d center,
Point3d chordPoint,
double leaderLength,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
center As Point3d,
chordPoint As Point3d,
leaderLength As Double,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
RadialDimension(
Point3d center,
Point3d chordPoint,
double leaderLength,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
center : Point3d *
chordPoint : Point3d *
leaderLength : float *
dimensionText : string *
dimensionStyle : ObjectId -> RadialDimension
Parameters
- center Point3d
- [in] Center point of the circle or arc to be measured.
- chordPoint Point3d
- [in] Chord point on the circle or arc to be measured, and to
which the dimension line is drawn.
- leaderLength Double
- [in] The distance from the chord point to the dogleg of the
dimension.
- dimensionText String
- [in] Dimension text to replace the measured value text.
- dimensionStyle ObjectId
- [in] ObjectId of the dimension style that is used to draw the
dimension entity.
See Also