RadialDimension Class

Wraps the OdDbRadialDimension class. Represents radial dimension entities.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Teigha.DatabaseServicesDimension
                Teigha.DatabaseServicesRadialDimension

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class RadialDimension : Dimension

The RadialDimension type exposes the following members.

Constructors
  Name Description
Public method RadialDimension The default constructor. Creates the radial dimension entity with the center and chord points at (0, 0, 0) and leader length of 0.0.
Protected method RadialDimension(IntPtr, Boolean) Initializes a new instance of the RadialDimension class
Public method RadialDimension(Point3d, Point3d, Double, String, ObjectId) Constructor. Creates a RadialDimension object with specified parameters.
Top
Properties
  Name Description
Public property Center Sets or gets the three-dimensional WCS coordinates that define the center point of the arc or circle being dimensioned.
Public property ChordPoint Sets or gets the three-dimensional WCS coordinates that define the intersection point of the dimension line and the arc or circle being dimensioned.
Public property Dimalttz Sets or gets the suppression of zeros in alternate tolerance values in dimension.
Value Description
0 Suppresses zero feet and zero inches.
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
12 Suppresses both leading and trailing zeros.
Public property Dimaltu Sets or gets the format of alternate units.
Value Description
1 Scientific format.
2 Decimal format.
3 Engineering format.
4 Architectural (stacked) format.
5 Fractions (stacked) format.
6 Architectural format.
7 Fractions format.
8 Microsoft® Windows® operating system default format.
Public property Dimaltz Sets or gets the suppression of zeros in alternate measurements in dimensions.
Value Description
0 Suppresses zero feet and zero inches
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
12 Suppresses both leading and trailing zeros.
Public property Dimatfit Sets or gets how arrows and text are placed when they do not fit within the extension lines of dimensions.
Value Description
0 Moves both text and arrowheads outside of extension lines.
1 Moves arrowheads outside of extension lines and text is placed between extension lines.
2 Moves text outside of extension lines and arrowheads are placed between extension lines.
3 Moves either text or arrowheads or both outside of the extension lines to provide the best fit. This is the initial value.
Public property Dimaunit Sets or gets the format for the angular measured value and angular tolerance value.
Value Description
0 Decimal degrees.
1 Degrees, minutes, and seconds.
2 Gradians.
3 Radians.
Public property Dimazin Sets or gets the suppression of zeros in angular measured values and tolerance.
Value Description
0 Includes all leading and trailing zeros.
1 Suppresses leading zeros.
2 Suppresses trailing zeros.
3 Suppresses leading and trailing zeros.
Public property Dimblk2s Sets or gets the name of the arrowhead block at the end of the second dimension line. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
"Small" Dot small blank
Public property Dimblks Sets or gets the name of the arrowhead block at the ends of dimension lines. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
"Small" Dot small blank
Public property Dimjust Sets or gets the horizontal justification for the dimension text box (relative to the extension lines).
Value Description
0 The text is centered within the extension lines.
1 The text is by the first extension line.
2 The text is by the second extension line.
3 The text is above the dimension line, parallel to the first extension line.
4 The text is above the dimension line, parallel to the second extension line.
Public property Dimldrblks Sets or gets the name of the arrowhead block at the ends of leader lines. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
"Small" Dot small blank
Public property Dimtad Sets or gets the vertical justification for the dimension text.
Value Description
0 The dimension text is centered vertically between two parts of the dimension line.
1 The dimension text is placed above the dimension line, except when the dimension line is not horizontal and the dimension text box is aligned horizontally.
2 The dimension text box is placed on the side of the dimension line farthest from the defining point.
3 The dimension text is positioned according to Japanese Industrial Standards.
4 The dimension text is placed under the dimension line.
Public property Dimtzin Sets or gets the suppression of zeros in primary tolerance values in dimension.
Value Description
0 Suppresses zero feet and zero inches.
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
12 Suppresses both leading and trailing zeros.
Public property LeaderLength Sets or gets the length from the ChordPoint to the dogleg for this radial dimension entity.
Top
Methods
  Name Description
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.