LinearEntity3dIsPerpendicularTo(PlanarEntity,
Tolerance) Method
|
Checks whether the specified plane is
perpendicular to this linear entity according to a tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPerpendicularTo(
PlanarEntity plane,
Tolerance tolerance
)
Public Function IsPerpendicularTo (
plane As PlanarEntity,
tolerance As Tolerance
) As Boolean
public:
bool IsPerpendicularTo(
PlanarEntity^ plane,
Tolerance tolerance
)
member IsPerpendicularTo :
plane : PlanarEntity *
tolerance : Tolerance -> bool
Parameters
- plane PlanarEntity
- [in] Plane to test for being perpendicular to this linear
entity.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if the specified plane is perpendicular to this linear entity,
false otherwise.
See Also