LayoutPaperPEDrawPaper Method

This method is called during vectorization to draw the paper.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract bool DrawPaper(
        Layout layout,
        WorldDraw worldDraw,
        Point3dCollection points
)

Parameters

layout  Layout
[in] Layout that is being vectorized.
worldDraw  WorldDraw
[in/out] Draw object that can be used by this function to set the necessary attributes and create the necessary geometry.
points  Point3dCollection
[in] Collection of points that contains the four corners of the paper.

Return Value

Boolean
true if the paper is successfully drawn, or false if the layout uses a default rendering of the paper.
See Also

©  Bricsys NV. All rights reserved.