EntityGetGraphicsMarkersAtSubentityPathIntPtr
Method
|
Entities use a mechanism of graphics system
markers to draw themselves. This mechanism associates an integer
identifier called a graphics system marker (or, GS marker) with
each primitive or with groups of primitives. Using specific
selection mechanisms, the GS marker for the actual subentity
selected on the screen can be retrieved and used for various
purposes, for example highlighting/unhighlighting the subentity on
the screen, hiding/unhiding it, etc. This method returns all
graphics system markers by subentity paths for complex entities
that have the ability to associate an integer identifier (GS
marker) with each graphics primitive or with groups of primitives
during the draw.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual IntPtrCollection GetGraphicsMarkersAtSubentityPathIntPtr(
FullSubentityPath subPath
)
Public Overridable Function GetGraphicsMarkersAtSubentityPathIntPtr (
subPath As FullSubentityPath
) As IntPtrCollection
public:
virtual IntPtrCollection^ GetGraphicsMarkersAtSubentityPathIntPtr(
FullSubentityPath subPath
)
abstract GetGraphicsMarkersAtSubentityPathIntPtr :
subPath : FullSubentityPath -> IntPtrCollection
override GetGraphicsMarkersAtSubentityPathIntPtr :
subPath : FullSubentityPath -> IntPtrCollection
Parameters
- subPath FullSubentityPath
- [in] The full subentity path to a subentity for which to get GS
markers.
Return Value
IntPtrCollection
See Also