IntPtrCollection Class

This class represents a collection of IntPtr values.
Inheritance Hierarchy
SystemObject
  Teigha.GeometryIntPtrCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class IntPtrCollection : IList

The IntPtrCollection type exposes the following members.

Constructors
  Name Description
Public method IntPtrCollection Default constructor for the IntPtrCollection class. Creates an empty collection of IntPtr values.
Public method IntPtrCollection(Int32) Constructor for the IntPtrCollection class. Creates an empty collection of IntPtr values with start capacity.
Public method IntPtrCollection(IntPtr) Constructor for the IntPtrCollection class. Creates a collection of IntPtr values from the passed array.
Top
Properties
  Name Description
Public property Capacity Represents the number of elements that this collection can contain.
Public property Count Represents the number of elements that this collection currently stores.
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method Add Adds an IntPtr value to the collection.
Public method AddRange Adds a range of values to the end of this collection. This method grows the collection capacity if necessary.
Public method Clear Clears this collection of IntPtr values.
Public method Contains Checks whether this collection contains a value that matches the specified value.
Public method CopyTo Copies this collection of IntPtr values to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection.
Public method IEnumerable_GetEnumerator Returns the enumerator for this collection.
Public method IndexOf Returns the index of the value in the collection that matches the specified value.
Public method Insert Inserts the specified value to the collection at the provided index.
Public method Remove Removes a value from the collection that matches the specified value.
Public method RemoveAt Removes a value from the collection at the specified index.
Public method ToArray Returns this collection as an array of IntPtr values.
Public method TrimToSize Sets the capacity to the actual number of elements in this integer collection.
Top
Fields
  Name Description
Public fieldStatic member DefaultSize Default size of the collection.
Top
See Also

©  Bricsys NV. All rights reserved.