FieldEvaluatorLoader Class

This class is used to load the evaluators required for evaluating fields.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesFieldEvaluatorLoader

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class FieldEvaluatorLoader : RXObject

The FieldEvaluatorLoader type exposes the following members.

Constructors
  Name Description
Public method FieldEvaluatorLoader Default constructor for the FieldEvaluatorLoader class.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method FindEvaluator Finds an evaluator for a field that does not have an evaluator ID.
Public method GetEvaluator The field engine calls this method to get the evaluator using the evaluator ID and uses the evaluator to evaluate the field.
Top
Remarks
This class acts as the interface between the field framework and the applications that implement evaluators. An application that implements evaluators should derive from this class and register an object of this class with the field engine when the application is loaded. The registered loader is used by the engine to obtain the evaluator object. Only one loader object is required for an application and it can support multiple evaluators. The loader objects are maintained globally and are used by all open documents.
See Also

©  Bricsys NV. All rights reserved.