CurveGetClosestPointTo(Point3d, Vector3d, Boolean) Method

Returns the point on this curve closest to the given point. This curve is projected on a plane that is defined by a normal to the plane.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual Point3d GetClosestPointTo(
        Point3d givenPoint,
        Vector3d direction,
        bool extend
)

Parameters

givenPoint  Point3d
[in] Point for which to calculate the closest point on this curve.
direction  Vector3d
[in] Direction of the normal vector to the projection plane.
extend  Boolean
[in] Extends this curve if and only if true.

Return Value

Point3d
See Also

©  Bricsys NV. All rights reserved.