QuadBoundary Class

'AcBoundary' class represents an array of loops being the boundary of a planar domain. The first item is the outer loop, all further item(s) are one or more inner loop(s).
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.QuadQuadBoundary

Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class QuadBoundary : DisposableWrapper

The QuadBoundary type exposes the following members.

Constructors
  Name Description
Public method QuadBoundary Initializes a new instance of the QuadBoundary class
Top
Properties
  Name Description
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method getAsCurves  
Public method getAsRegion Service method to get the boundary as AcDbRegion (will be initialised as NULL); return value of 'true' guarantees a non-null AcDbRegion
Public method isValid Returns 'true' if this boundary is valid; returns 'false' for an empty boundary
Public method overlapsWithFaceEdge Returns 'true' if an edge overlaps with an edge of the face it belongs to, if any
Public method path Returns path to a 'face' subentity, if the boundary belongs to any; may be empty
Public method plane Returns the plane, the loops belong to
Top
See Also

©  Bricsys NV. All rights reserved.