RegionAreaProperties Method
|
Calculates the area properties of the region.
The method validates the origin, xAxis, and yAxis parameters to
ensure that: * axes are perpendicular to each other. * axes and the
origin lie in the same plane as the region.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual RegionAreaProperties AreaProperties(
ref Point3d origin,
ref Vector3d xAxis,
ref Vector3d yAxis
)
Public Overridable Function AreaProperties (
ByRef origin As Point3d,
ByRef xAxis As Vector3d,
ByRef yAxis As Vector3d
) As RegionAreaProperties
public:
virtual RegionAreaProperties AreaProperties(
Point3d% origin,
Vector3d% xAxis,
Vector3d% yAxis
)
abstract AreaProperties :
origin : Point3d byref *
xAxis : Vector3d byref *
yAxis : Vector3d byref -> RegionAreaProperties
override AreaProperties :
origin : Point3d byref *
xAxis : Vector3d byref *
yAxis : Vector3d byref -> RegionAreaProperties
Parameters
- origin Point3d
- [in] Origin of the coordinate system to use for evaluation
(WCS).
- xAxis Vector3d
- [in] X axis of the coordinate system to use for evaluation
(WCS).
- yAxis Vector3d
- [in] Y axis of the coordinate system to use for evaluation
(WCS).
Return Value
RegionAreaProperties
Calculated area properties of a region.
Remarks
Returned values
are measured using the values of origin, xAxis, yAxis parameters.
and are represented in WCS coordinates. This method is implemented
only for Spatial modeler and throws the eNotImplementedYet exception for other
modelers.
See Also