RegionAreaProperties Structure

This class stores data that is used for the AreaProperties property of a region.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesRegionAreaProperties

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct RegionAreaProperties

The RegionAreaProperties type exposes the following members.

Properties
  Name Description
Public property Area Property that represents an area of a region.
Public property Centroid Property that represents the centroid point of a region.
Public property Extents Property that represents extents of a region.
Public property MomentsOfInertia Property that represents the moments of inertia of a region.
Public property Perimeter Property that represents perimeter of a region.
Public property PrincipalAxes Property that represents principal axes of a region. The passed parameter can be 0 or 1 and represents an index of the returned principal axis.
Public property PrincipalMoments Property that represents the principal moments of a region.
Public property ProductOfInertia Property that represents the product of inertia of a region.
Public property RadiiOfGyration Property that represents the radii of gyration of a region.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.