SubDMeshGetObjectMesh Method

Creates a mesh from the specified object based on the specified mesh facet settings.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static MeshDataCollection GetObjectMesh(
        DBObject dbObj,
        MeshFaceterData faceterData
)

Parameters

dbObj  DBObject
[in] Object from which the mesh is generated.
faceterData  MeshFaceterData
[in] Facet data of a mesh.

Return Value

MeshDataCollection
Mesh data from the specified object.
Remarks
The modeler of the object (ModelerGeometry, SpaModeler, or C3dModeler) affects the result of the method. Current triangulation settings also affect the result, as MeshFaceterSettings may not override all of them.
See Also

©  Bricsys NV. All rights reserved.