MeshFaceterData Structure

This structure stores data used by the SubDMesh.GetObjectMesh method.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesMeshFaceterData

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MeshFaceterData

The MeshFaceterData type exposes the following members.

Constructors
  Name Description
Public method MeshFaceterData Initializes a new instance of the MeshFaceterData class
Top
Properties
  Name Description
Public property FaceterDevNormal Property that represents the maximum normal deviation (angle between facets in the mesh).
Public property FaceterDevSurface Property that represents the maximum surface deviation.
Public property FaceterGridRatio Property that represents the maximum aspect ratio for the grid (grid quads).
Public property FaceterMaxEdgeLength Property that represents the maximum edge length.
Public property FaceterMaxGrid Property that represents the maximum number of grid lines to use.
Public property FaceterMeshType  
Public property FaceterMinUGrid Property that represents the minimum number of the U parameter for grid lines.
Public property FaceterMinVGrid Property that represents the minimum number of the V parameter for grid lines.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.