SphereIntersectWith(LinearEntity3d,
Tolerance) Method
|
Calculates intersection points with the
specified linear entity according to a geometric tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] IntersectWith(
LinearEntity3d linearEntity,
Tolerance tolerance
)
Public Function IntersectWith (
linearEntity As LinearEntity3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ IntersectWith(
LinearEntity3d^ linearEntity,
Tolerance tolerance
)
member IntersectWith :
linearEntity : LinearEntity3d *
tolerance : Tolerance -> Point3d[]
Parameters
- linearEntity LinearEntity3d
- [in] Linear entity with which to calculate intersections.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
The returned array consists of two elements. The first element
corresponds to the first intersection point (if it exists), and the
second element corresponds to the second intersection point (if it
exists). If the method fails or there are no intersection points,
this method returns nullptr.
See Also