DatabaseSaveAs(String, SecurityParameters) Method

Saves content of the currently active database according to the passed file name and security parameters.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void SaveAs(
        string fileName,
        SecurityParameters security
)

Parameters

fileName  String
[in] File name to write the database to. File extension is not appended automatically.
security  SecurityParameters
[in] A SecurityParameters class that represents security parameters such as password, provider name, serial number, etc.
Remarks
If security is non-NULL, its settings ignore any previous database security settings, otherwise previous security settings remain unchanged. If the security parameters are not properly initialized, the method fails. If .dwg files can no longer be saved with passwords specified in security parameters.
See Also

©  Bricsys NV. All rights reserved.