SubentityOverruleTransformSubentPathsBy
Method
|
Overrules the
Entity.subTransformSubentPathsBy() method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void TransformSubentPathsBy(
Entity entity,
FullSubentityPath[] paths,
Matrix3d xform
)
Public Overridable Sub TransformSubentPathsBy (
entity As Entity,
paths As FullSubentityPath(),
xform As Matrix3d
)
public:
virtual void TransformSubentPathsBy(
Entity^ entity,
array<FullSubentityPath>^ paths,
Matrix3d xform
)
abstract TransformSubentPathsBy :
entity : Entity *
paths : FullSubentityPath[] *
xform : Matrix3d -> unit
override TransformSubentPathsBy :
entity : Entity *
paths : FullSubentityPath[] *
xform : Matrix3d -> unit
Parameters
- entity Entity
- [in] Entity.
- paths FullSubentityPath
- [in] Array of paths.
- xform Matrix3d
- [in] Transformation matrix to be applied to each
subentity.
See Also