SubentityOverrule Class

This class overrules a subset of subentity linked operations that an entity specifies. It is used as a base class for classes derived from OdDbEntity to change their behavior. Each default implementation calls the corresponding method of the target class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.DatabaseServicesSubentityOverrule

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class SubentityOverrule : Overrule

The SubentityOverrule type exposes the following members.

Constructors
  Name Description
Protected method SubentityOverrule Initializes a new instance of the SubentityOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method AddSubentPaths Overrules the Entity.subAddSubentPaths() method and calls it in the default implementation.
Public method DeleteSubentPaths Overrules the Entity.subDeleteSubentPaths() method and calls it in the default implementation.
Public method GetCompoundObjectTransform Overrules the Entity.subGetCompoundObjectTransform() method and calls it in the default implementation.
Public method GetGripPointsAtSubentPath Overrules the Entity.subGetGripPointsAtSubentPath() method and calls it in the default implementation.
Public method GetGsMarkersAtSubentPath Overrules the Entity.subGetGsMarkersAtSubentPath() method and calls it in the default implementation.
Public method GetSubentClassId Overrules the Entity.subGetSubentClassId() method and calls it in the default implementation.
Public method GetSubentPathGeomExtents Overrules the Entity.subGetSubentPathGeomExtents() method and calls it in the default implementation.
Public method GetSubentPathsAtGsMarker Overrules the Entity.subGetSubentPathsAtGsMarker() method and calls it in the default implementation.
Public method MoveGripPointsAtSubentPaths Overrules the Entity.subMoveGripPointsAtSubentPaths() method and calls it in the default implementation.
Public method OnSubentGripStatusChanged Overrules the Entity.subentGripStatus() method and calls it in the default implementation.
Public method SetCustomFilter Enables use of the IsApplicable method to check whether an overrule is applied.
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter Enables use of an extension dictionary lookup for checking whether an overrule is applied.
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter Enables use of ID lookups for checking whether an overrule is applied.
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter Disables the filter methods (SetCustomFilter, SetExtensionDictionaryEntryFilter, SetIdFilter, SetXDataFilter) and the IsApplicable() method for checking whether an overrule is applied.
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter Enables the use of xdata for checking whether an overrule is applied.
(Overrides OverruleSetXDataFilter(String))
Public method SubentPtr Overrules the Entity.subentPtr() method and calls it in the default implementation.
Public method TransformSubentPathsBy Overrules the Entity.subTransformSubentPathsBy() method and calls it in the default implementation.
Top
See Also

©  Bricsys NV. All rights reserved.