CircularArc3dProjectedIntersectWith(LinearEntity3d,
Vector3d, Tolerance) Method
|
Retrieves intersection points between this
circular arc and a projected line.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ProjectedIntersectWith(
LinearEntity3d line,
Vector3d projectionDirection,
Tolerance tolerance
)
Public Function ProjectedIntersectWith (
line As LinearEntity3d,
projectionDirection As Vector3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
LinearEntity3d^ line,
Vector3d projectionDirection,
Tolerance tolerance
)
member ProjectedIntersectWith :
line : LinearEntity3d *
projectionDirection : Vector3d *
tolerance : Tolerance -> Point3d[]
Parameters
- line LinearEntity3d
- [in] Line to be projected.
- projectionDirection Vector3d
- [in] Projection direction.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
Array of intersection points.
See Also