Curve3dGetNormalPoint(Point3d,
Tolerance) Method
|
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve3d GetNormalPoint(
Point3d point,
Tolerance tolerance
)
Public Function GetNormalPoint (
point As Point3d,
tolerance As Tolerance
) As PointOnCurve3d
public:
PointOnCurve3d^ GetNormalPoint(
Point3d point,
Tolerance tolerance
)
member GetNormalPoint :
point : Point3d *
tolerance : Tolerance -> PointOnCurve3d
Parameters
- point Point3d
- [in] Point for which corresponding point on this curve is
retrieved.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
PointOnCurve3d
Point whose normal passes through the input point.
See Also