GeometryMesh Method

Introduces a mesh into the vectorization context.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract bool Mesh(
        int rows,
        int columns,
        Point3dCollection points,
        EdgeData edgeData,
        FaceData faceData,
        VertexData vertexData,
        bool bAutoGenerateNormals
)

Parameters

rows  Int32
[in] Number of rows.
columns  Int32
[in] Number of columns.
points  Point3dCollection
[in] Array of vertices.
edgeData  EdgeData
[in] Additional edge data.
faceData  FaceData
[in] Additional face data.
vertexData  VertexData
[in] Additional vertex data.
bAutoGenerateNormals  Boolean
[in] Flag that indicates whether the display system should automatically generate normals for vertices and faces if they are not specified within the vertexData and faceData parameters.

Return Value

Boolean
true. This method also throws a corresponding exception if it fails.
Remarks
A mesh is a surface defined by a grid of vertices and corresponds to a polygon mesh. By default, a mesh takes on the current color. Color, linetype, and other properties can be controlled by supplying the appropriate data for the edgeData, faceData, and vertexData arguments. * vertexData array must have rows * columns elements. * The arrays in *edgeData must be NULL or contain (rows - 1) * columns + rows x (columns -1) elements. * The arrays in *faceData must be NULL or contain (rows - 1) * (columns - 1) elements. * The arrays in *vertexData must be NULL or contain rows x columns elements.
See Also

©  Bricsys NV. All rights reserved.