FaceData Class

This class stores optional data that can be assigned for a set of faces in a mesh or in shell geometry. An object of this class can be passed as a parameter to the mesh and shell methods of geometry classes.
Inheritance Hierarchy
SystemObject
  Teigha.GraphicsInterfaceFaceData

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class FaceData

The FaceData type exposes the following members.

Constructors
  Name Description
Public method FaceData Initializes a new instance of the FaceData class
Top
Methods
  Name Description
Public method GetColors Returns an array of color indices for geometry faces.
Public method GetLayers Returns an array of layer object identifiers for geometry faces.
Public method GetMappers Returns an array of mappers for geometry faces.
Public method GetMaterials Returns an array of material object identifiers for geometry faces.
Public method GetNormalVectors Returns an array of normal vectors for geometry faces.
Public method GetSelectionMarkers Returns an array of selection markers for geometry faces.
Public method GetTransparency Returns an array of transparency objects for geometry faces.
Public method GetTrueColors Returns an array of colors for geometry faces.
Public method GetVisibility Returns an array of visibility values for geometry faces.
Public method SetColors Sets an array of color indices for geometry faces.
Public method SetLayers Sets an array of layers for geometry faces.
Public method SetMappers Sets an array of mappers for geometry faces.
Public method SetMaterials Sets an array of materials for geometry faces.
Public method SetNormalVectors Sets an array of normals for geometry faces.
Public method SetSelectionMarkers Sets an array of selection markers for geometry faces.
Public method SetTransparency Sets an array of transparency objects for geometry faces.
Public method SetTrueColors Sets an array of colors for geometry faces.
Public method SetVisibility Sets an array of visibility values for geometry faces.
Top
See Also

©  Bricsys NV. All rights reserved.