DBObjectWblockClone Method

Performs a shallow clone of this object.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual DBObject WblockClone(
        RXObject ownerPointer,
        IdMapping idMap,
        bool isPrimary
)

Parameters

ownerPointer  RXObject
[in] Pointer to the owner object.
idMap  IdMapping
[in/out] Object ID mapping object.
isPrimary  Boolean
[in] Flag indicating whether this object is primary or owned.

Return Value

DBObject
Remarks
Returns a handle to the newly created clone and adds a record to the specified ID mapping object. If the cloning operation fails, null is returned. A shallow clone is a clone of only this object. This function should not be called by client code; use Database.wblockCloneObjects() instead. The default implementation of this function calls subWblockClone() for all objects hard-referenced by this object. This function can be overridden in custom classes.
See Also

©  Bricsys NV. All rights reserved.