EntityGetGripPoints(GripDataCollection,
Double, Int32, Vector3d,
GetGripPointsFlags) Method
|
Returns all grip points of this entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool GetGripPoints(
GripDataCollection grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
Public Overridable Function GetGripPoints (
grips As GripDataCollection,
curViewUnitSize As Double,
gripSize As Integer,
curViewDir As Vector3d,
bitFlags As GetGripPointsFlags
) As Boolean
public:
virtual bool GetGripPoints(
GripDataCollection^ grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
abstract GetGripPoints :
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> bool
override GetGripPoints :
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> bool
Parameters
- grips GripDataCollection
- [in/out] Receives a collection of grips. May contain elements
before method execution; new elements are appended to the end of
the collection.
- curViewUnitSize Double
- [in] Size, in pixels, of one drawing unit in the current
viewport.
- gripSize Int32
- [in] Current grip size, in pixels.
- curViewDir Vector3d
- [in] Vector direction in the current viewport.
- bitFlags GetGripPointsFlags
- [in] Bit flags specified by the GetGripPointsFlags
enumeration.
Return Value
Boolean
true if this method is implemented,
false otherwise.
See Also