MenuItemCollection Class

This class is a container for MenuItem objects.
Inheritance Hierarchy
SystemObject
  Teigha.RuntimeMenuItemCollection

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class MenuItemCollection : IList, 
        IEnumerable<IMenuItem>, IDisposable

The MenuItemCollection type exposes the following members.

Constructors
  Name Description
Public method MenuItemCollection Constructor for the MenuItemCollection class.
Top
Properties
  Name Description
Public property Count Property that represents the count of elements in the collection.
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property Item Property that represents the item in the collection at the specified index.
Top
Methods
  Name Description
Public method Add Adds a menu item to the collection.
Public method Clear Clears this collection.
Public method Contains Checks whether the collection contains the specified menu item.
Public method CopyTo Copies items from this collection to the specified array.
Public method Dispose Releases all resources used by the MenuItemCollection
Protected method Dispose(Boolean) Releases the unmanaged resources used by the MenuItemCollection and optionally releases the managed resources
Public method GetEnumerator Returns an enumerator object for the collection.
Public method IndexOf Returns index of the specified menu item in this collection.
Public method Insert Inserts a menu item to this collection.
Public method Remove Removes the specified menu item from this collection.
Public method RemoveAt Removes a menu item at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.