MenuItem Class

This class represents menu items.
Inheritance Hierarchy
SystemObject
  Teigha.RuntimeMenu
    Teigha.RuntimeMenuItem

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class MenuItem : Menu, IMenuItem, 
        IDisposable

The MenuItem type exposes the following members.

Constructors
  Name Description
Public method MenuItem(String) Constructor for the MenuItem class.
Public method MenuItem(String, Icon) Constructor for the MenuItem class.
Top
Properties
  Name Description
Public property Checked Property that indicates whether the menu item is checked.
Public property Enabled Property that indicates whether the menu item is enabled.
Public property Icon Property that represents icon of the menu item.
Public property Items This property represents menu items of a menu.
Public property MenuItems This property represents menu items of a menu.
(Overrides MenuMenuItems)
Public property Text Property that represents the text string of a menu item.
Public property Visible Property that indicates whether the menu item is visible.
Top
Methods
  Name Description
Public method Dispose Releases all resources used by the MenuItem
Protected method Dispose(Boolean) Releases the unmanaged resources used by the MenuItem and optionally releases the managed resources
Public method OnClicked Invokes the Click event.
Top
Events
  Name Description
Public event Click Event handler for click events.
Top
See Also

©  Bricsys NV. All rights reserved.