Creates layers, changes their properties, and removes layers through the Drawing Explorer.
Accessing the Command
command bar: layer
aliases: la, ddlmodes, explayers
menu bar: Settings | Layers and Tools | Drawing Explorer | Layers
toolbar: Entity Properties |
and Layers |
status bar: Layer field ( 0 )
: layer
Displays the Layers section of the Drawing Explorer dialog box:
Create layers or modify layer properties, and then click X.
Press F1 to access help.
When you open the Drawing Explorer - Layers dialog when in paper space, additional columns display: New, VP Freeze, VP Color, VP Linetype, VP Lineweight and VP Plot Style (VP is short for Viewport). By default, these columns match the corresponding model space settings. VP layer properties can be set differently for each layout and for each paper space viewport.
If SHOWLAYERUSAGE is on, the Layer Usage icons indicate whether VP settings for the current layout or paper space viewport are different from the model space settings:
: Current layer with VP
overrides.
: Layer with VP overrides.
: Empty layer with VP
overrides.
If no paper space viewport is active, the VP settings apply to entities in the current layout.
If a viewport is active, the VP settings override the BYLAYER properties in the current viewport.
The VP Freeze
setting ( or
)allows to control the visibility of model space
entities in the current viewport.
The New setting controls whether a layer
is either Frozen () are Thawed (
) in a new paper space viewport.
Create or modify VP layer properties, and then click X.
Press F1 to access help.
Select the layer(s), then right click and choose Remove Viewport Overrides in the context menu.
The options are:
From Selected Layers
For Current Viewport
For All Viewports
From All Layers
For Current Viewport
For All Viewports
Option |
Description |
Drawings |
Toggles the display of the Drawings panel. |
Details |
Toggles the display of the Details panel. |
Preview |
Toggles the display of the Preview panel. |
StatusBar |
Toggles the display of the Status Bar. |
Filters |
Toggles the display of the Filters panel. |
Details |
Switches the display in the Details panel to Details view. |
Icons |
Switches the display in the Details panel to Icons view. |
Regen |
Forces the drawing display to be regenerated. |
Toggle Regen |
Toggles the automatic regen of the drawing display. |
Toggles the display of Xref layers in the Details panel. |
|
Indicate layers in use |
Toggles the SHOWLAYERUSAGE system variable On/Off. |
Apply layer filter to layer toolbar |
Applies the current layer filter to the Layer control on the Entity Properties toolbar. |
Command Options
Option |
Description |
Creates new layers. A new layer is created as a copy of the currently selected layer. |
|
Deletes layers from Drawing Explorer. The following layers cannot be deleted:
|
|
Purges layers from the current drawing. The following layers cannot be purged:
|
|
|
If pressed, displays layers of which the name fits the Filter Text field only:
Accepted wild-card characters are listed in the Wild-Card Table below. |
Displays the current layer filter. Click the down-arrow button to choose a different layer filter. All and All Used Layers are built-in layer filters. Choose All to see all layers in the list; choose All Used Layers to list non-empty layers only. If the drawing contains external references (Xrefs) a layer filter definitions for Xref layers and for each Xref are created automatically. Choose Show XRef Layers in the View menu to display the Xref layers in the Details pane.
|
|
To toggle the display of the Filter Panel On/Off do one of the following:
If the drawing contains external references (Xrefs) a layer filter definitions for Xref layers and for each Xref are created automatically. Choose Show XRef Layers in the View menu to display the Xref layers in the Details pane.
On the Filter Panel:
To create a new layer filter definition:
|
|
Click the Invert Filter button to invert the current filter. |
|
|
|
Specifies the current working layer. Only one layer can be current at a time. |
|
|
If the SHOWLAYERUSAGE system variable is ON, the following icons display in the Layer Usage column:
When in a paper space layout or in a paper space viewport (model space with floating viewports) the following icons indicate VP overrides exist:
The Indicate layers in use item in the View menu toggles the SHOWLAYERUSAGE system variable ON/Off.
|
|
|
Specifies the name of the layer.
|
|
(option) Describes the content of the layer. Click the field, then type. |
|
Toggles the selected layers between on and off:
Click a lightbulb icon to change its status. |
|
Toggles the selected layers between frozen and thawed:
Click an icon to toggle its status. |
|
Toggles the selected layers between locked and unlocked:
Click an icon to toggle its status. |
|
Specifies the color of the layer. Default color is white (black). To change the color: 1. Click a color square to see the Select Color dialog box.
2. Choose a color, and then click OK. See Color command. |
|
Specifies the linetype of selected layers. Default is "Continuous." To change the linetype:
To load additional linetype definitions:
See Linetype command. |
|
Specifies the linetype of selected layers. Default is "Default." To change the lineweight:
See LWeight command. |
|
|
Specifies the plot style of selected layers. Default is "Color_7." To change the plot style"
Plot styles are available only when they are enabled in the drawing; by default, they are not. See PlotStyle command. |
Toggles the selected layers between plotable and not plotable:
Click an icon to toggle its status. |
|
Specifies whether the layer is visible (thawed) or invisible (frozen) in a new layout viewport. |
|
Specifies the material of selected layers. Default is "Global." To change the material:
|
|
Displays the entities on the selected layer. |
Wild-card characters can be used in the Filter text field and in Filter definitions to filter layers by name.
Character |
Name |
ASCII code* |
Result |
Example |
# |
pound |
35 |
Matches numeric digits. |
## matches any 2 digit number: 12 or 34 but not 5 or 123 |
@ |
at |
64 |
Matches alphabetic characters. |
@@@@@ matches all 5-letter layer names |
. |
period |
46 |
Matches non-alphanumeric characters. |
.* matches all layer names starting with an non-alphanumeric character: _SITEPLAN or +1_LEVEL |
* |
asterisk |
42 |
Matches any character string. |
*A* matches all layer names containing the letter A |
? |
question mark |
63 |
Matches any single character. |
?AB* matches LABORATORY and CABARET but not STABLE |
~ |
tilde |
126 |
Matches any string but the pattern. |
~*A* matches all layer names not containing the letter A |
[] |
brackets |
91 93 |
Matches any one of the characters enclosed. |
LA[YB] matches LAY and LAB |
[~] |
|
|
Matches any one of the characters not enclosed. |
LA[~YB] matches LAD but not LAY or LAB |
[-] |
|
|
Specifies a range for a single character. |
LAY-[A-E] matches any combination of LAY- and A through E: LAY-A ... LAY-E but not LAY-F |
` |
reverse quote |
96 |
Matches the next string exactly. |
Allows to find a layer name that contains a wild-card character. If preceded with a reverse quote, it is not interpreted as a wild-card character. `~LAY* matches ~LAY-1,~LAYER-1, ~LAY-B, &ldots; |
* ASCII code: if a character is not available on the keyboard, press and hold the Alt-key and type the ASCII code on the numeric keypad.
Shortcut Menu Options
Right-click layer names in Drawing Explorer to see the following shortcut menu:
Option |
Keystroke |
Description |
New |
Ctrl+N |
Creates new layers. |
Delete |
Ctrl+D |
Deletes layers from Drawing Explorer. The following layers cannot be deleted:
|
Purge |
Ctrl+P |
Purges layers from the current drawing. The following layers cannot be purged:
|
Cut |
Ctrl+X |
Cuts the layer and its properties to the Clipboard. |
Copy |
Ctrl+C |
Copies the layer and its properties to the Clipboard. |
Paste |
Ctrl+V |
Pastes the layer from the Clipboard into Drawing Explorer. |
Rename |
|
Renames the selected layer. |
Select All |
|
Selects all layers. |
Set Current |
|
Specifies the current working layer. Only one layer can be current at a time. |
Right-click O (or other layer name) on the status bar for the shortcut menu:
Shortcut Menu |
Description |
0, et cetera |
Chooses the current working layer. When the drawing contains additional layers, their names are listed here. |
Properties
|
Opens the Layers section of the Drawing Explorer. |
Procedures
To merge the content of two layers
Related Commands
-Layer - creates layers and changes their properties in the command bar.
LayerState - saves and restores layer states.
LayMCur - changes the working layer to that of a selected entity
LayFrz - freezes layers associated with selected entities.
LayThw - thaws all frozen layers.
LayIso - isolates layers associated with selected entities.
LayLck - locks layers associated with selected entities.
LayUlk - unlocks layers associated with selected entities.
LayOff - turns off layers associated with selected entities.
LayOn - turns on all layers that have been turned off.
Materials - Creates materials and edits their properties through the Drawing Explorer.
Explorer - Opens the Drawing Explorer dialog box.
© Menhirs NV. All rights reserved. |