DxfFiler Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class DxfFiler : RXObject

The DxfFiler type exposes the following members.

Constructors
  Name Description
Protected method DxfFiler
Initializes a new instance of the DxfFiler class
Protected method DxfFiler(IntPtr, Boolean)
Initializes a new instance of the DxfFiler class
Top
Properties
Methods
  Name Description
Public method AtSubclassData
Public method HaltAtClassBoundaries
Public method PushBackItem
Public method ReadAngle
Public method ReadBoolean
Public method ReadByte
Public method ReadBytes
Public method ReadDouble
Public method ReadHandle
Public method ReadInt16
Public method ReadInt32
Public method ReadInt64
Public method ReadObjectId
Public method ReadPoint2d
Public method ReadPoint3d
Public method ReadResultBuffer
Public method ReadScale3d
Public method ReadString
Public method ReadUInt16
Public method ReadUInt32
Public method ReadUInt64
Public method ReadVector2d
Public method ReadVector3d
Public method ResetFilerStatus
Public method RewindFiler
Public method Seek
Public method SetError(String, String)
Public method SetError(ErrorStatus, String, String)
Public method WriteAngle
Public method WriteBoolean
Public method WriteByte
Public method WriteBytes
Public method WriteDouble
Public method WriteEmbeddedObjectStart
Public method WriteHandle
Public method WriteInt16
Public method WriteInt32
Public method WriteInt64
Public method WriteName
Public method WriteObjectId
Public method WritePoint2d
Public method WritePoint3d
Public method WriteResultBuffer
Public method WriteScale3d
Public method WriteString
Public method WriteUInt16
Public method WriteUInt32
Public method WriteUInt64
Public method WriteVector2d
Public method WriteVector3d
Public method WriteXDataStart
Top
See Also

©  Bricsys NV. All rights reserved.