Assoc3dNetwork Class

Inheritance Hierarchy
SystemObject
  Bricscad.Geometrical3dConstraintsAssoc3dNetwork
Namespace:  Bricscad.Geometrical3dConstraints
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public sealed class Assoc3dNetwork

The Assoc3dNetwork type exposes the following members.

Constructors
  Name Description
Public method Assoc3dNetwork
Initializes a new instance of the Assoc3dNetwork class
Top
Methods
  Name Description
Public methodStatic member Get3dComponentParameterExpression
Returns the expression string for specified component parameter
Public methodStatic member Get3dComponentParametersNames
Returns all parameters of specified assembly component
Public methodStatic member Get3dComponentParameterStringValue
Returns the string value for specified component parameter
Public methodStatic member Get3dComponentParameterValue
Returns the expression value for specified component parameter
Public methodStatic member Get3dConstraintsGroup
Returns the 3D constraints group for specified block table record
Public methodStatic member GetAll3dConstraintsGroups
Returns all 3D constraints group for specified database
Public methodStatic member SetComponentParameterExpression
Sets a new expression for component parameter
Top
See Also

©  Bricsys NV. All rights reserved.