CurveCurveIntersector2d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class CurveCurveIntersector2d : Entity2d

The CurveCurveIntersector2d type exposes the following members.

Constructors
  Name Description
Public method CurveCurveIntersector2d
Initializes a new instance of the CurveCurveIntersector2d class
Public method CurveCurveIntersector2d(IntPtr, Boolean)
Initializes a new instance of the CurveCurveIntersector2d class
Public method CurveCurveIntersector2d(Curve2d, Curve2d)
Initializes a new instance of the CurveCurveIntersector2d class
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Tolerance)
Initializes a new instance of the CurveCurveIntersector2d class
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval)
Initializes a new instance of the CurveCurveIntersector2d class
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval, Tolerance)
Initializes a new instance of the CurveCurveIntersector2d class
Top
Properties
Methods
  Name Description
Public method ChangeCurveOrder
Public methodStatic member Create
Public method GetIntersectionParameters
Public method GetIntersectionPoint
Public method GetIntersectionPointTolerance
Public method GetIntersectionRanges
Public method GetOverlapRanges
Public method GetPointOnCurve1
Public method GetPointOnCurve2
Public method IsTangential
Public method IsTransversal
Public method OrderWithRegardsTo1
Public method OrderWithRegardsTo2
Public method Set(Curve2d, Curve2d)
Public method Set(Curve2d, Curve2d, Tolerance)
Public method Set(Curve2d, Curve2d, Interval, Interval)
Public method Set(Curve2d, Curve2d, Interval, Interval, Tolerance)
Top
See Also

©  Bricsys NV. All rights reserved.