SurfaceSurfaceIntersector Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class SurfaceSurfaceIntersector : Entity3d

The SurfaceSurfaceIntersector type exposes the following members.

Constructors
  Name Description
Public method SurfaceSurfaceIntersector
Initializes a new instance of the SurfaceSurfaceIntersector class
Public method SurfaceSurfaceIntersector(Surface, Surface)
Initializes a new instance of the SurfaceSurfaceIntersector class
Public method SurfaceSurfaceIntersector(Surface, Surface, Tolerance)
Initializes a new instance of the SurfaceSurfaceIntersector class
Top
Properties
  Name Description
Public property NumResults
Public property Surface1
Public property Surface2
Public property Tolerance
Top
Methods
  Name Description
Public methodStatic member Create
Public method GetDimension
Public method GetIntersectionConfigurations
Public method GetIntersectPointParameters
Public method GetType(Int32)
Public method IntersectCurve
Public method IntersectParameterCurve
Public method IntersectPoint
Public method Set(Surface, Surface)
Public method Set(Surface, Surface, Tolerance)
Top
See Also

©  Bricsys NV. All rights reserved.