GripOverrule Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class GripOverrule : Overrule

The GripOverrule type exposes the following members.

Constructors
  Name Description
Protected method GripOverrule
Initializes a new instance of the GripOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method GetGripPoints(Entity, Point3dCollection, IntegerCollection, IntegerCollection)
Public method GetGripPoints(Entity, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags)
Public method GetStretchPoints
Public method MoveGripPointsAt(Entity, IntegerCollection, Vector3d)
Public method MoveGripPointsAt(Entity, GripDataCollection, Vector3d, MoveGripPointsFlags)
Public method MoveStretchPointsAt
Public method OnGripStatusChanged
Public method SetCustomFilter (Overrides OverruleSetCustomFilter.)
Public method SetExtensionDictionaryEntryFilter (Overrides OverruleSetExtensionDictionaryEntryFilter(String).)
Public method SetIdFilter (Overrides OverruleSetIdFilter(ObjectId).)
Public method SetNoFilter (Overrides OverruleSetNoFilter.)
Public method SetXDataFilter (Overrides OverruleSetXDataFilter(String).)
Top
See Also

©  Bricsys NV. All rights reserved.