NonEntityTraits Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              Teigha.GraphicsInterfaceGradientBackgroundTraits
              Teigha.GraphicsInterfaceGroundPlaneBackgroundTraits
              Teigha.GraphicsInterfaceImageBackgroundTraits
              Teigha.GraphicsInterfaceLightTraits
              Teigha.GraphicsInterfaceRenderSettingsTraits
Namespace:  Teigha.GraphicsInterface
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class NonEntityTraits : SubEntityTraits

The NonEntityTraits type exposes the following members.

Constructors
  Name Description
Protected method NonEntityTraits
Initializes a new instance of the NonEntityTraits class
Top
Properties
  Name Description
Public property Color (Overrides SubEntityTraitsColor.)
Public property DrawFlags (Overrides SubEntityTraitsDrawFlags.)
Public property FillType (Overrides SubEntityTraitsFillType.)
Public property Layer (Overrides SubEntityTraitsLayer.)
Public property LineType (Overrides SubEntityTraitsLineType.)
Public property LineTypeScale (Overrides SubEntityTraitsLineTypeScale.)
Public property LineWeight (Overrides SubEntityTraitsLineWeight.)
Public property Mapper (Overrides SubEntityTraitsMapper.)
Public property Material (Overrides SubEntityTraitsMaterial.)
Public property PlotStyleDescriptor (Overrides SubEntityTraitsPlotStyleDescriptor.)
Public property Sectionable (Overrides SubEntityTraitsSectionable.)
Public property SelectionFlags (Overrides SubEntityTraitsSelectionFlags.)
Public property SelectionOnlyGeometry (Overrides SubEntityTraitsSelectionOnlyGeometry.)
Public property ShadowFlags (Overrides SubEntityTraitsShadowFlags.)
Public property Thickness (Overrides SubEntityTraitsThickness.)
Public property Transparency (Overrides SubEntityTraitsTransparency.)
Public property TrueColor (Overrides SubEntityTraitsTrueColor.)
Public property VisualStyle (Overrides SubEntityTraitsVisualStyle.)
Top
Methods
  Name Description
Public method AddLight (Overrides DrawableTraitsAddLight(ObjectId).)
Protected method SetLayerFlags (Overrides DrawableTraitsSetLayerFlags(DrawableTraitsLayerFlags).)
Public method SetSelectionMarker (Overrides SubEntityTraitsSetSelectionMarker(IntPtr).)
Public method SetupForEntity (Overrides DrawableTraitsSetupForEntity(Entity).)
Top
See Also

©  Bricsys NV. All rights reserved.