Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public abstract bool Shell(
Point3dCollection points,
IntegerCollection faces,
EdgeData edgeData,
FaceData faceData,
VertexData vertexData,
bool bAutoGenerateNormals
)
Public MustOverride Function Shell (
points As Point3dCollection,
faces As IntegerCollection,
edgeData As EdgeData,
faceData As FaceData,
vertexData As VertexData,
bAutoGenerateNormals As Boolean
) As Boolean
public:
virtual bool Shell(
Point3dCollection^ points,
IntegerCollection^ faces,
EdgeData^ edgeData,
FaceData^ faceData,
VertexData^ vertexData,
bool bAutoGenerateNormals
) abstract
abstract Shell :
points : Point3dCollection *
faces : IntegerCollection *
edgeData : EdgeData *
faceData : FaceData *
vertexData : VertexData *
bAutoGenerateNormals : bool -> bool
Parameters
- points
- Type: Teigha.GeometryPoint3dCollection
- faces
- Type: Teigha.GeometryIntegerCollection
- edgeData
- Type: Teigha.GraphicsInterfaceEdgeData
- faceData
- Type: Teigha.GraphicsInterfaceFaceData
- vertexData
- Type: Teigha.GraphicsInterfaceVertexData
- bAutoGenerateNormals
- Type: SystemBoolean
Return Value
Type:
Boolean
See Also