SurfaceRayTest Method

Creates a ray that starts from the specified point and has the specified direction.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void RayTest(
        Point3d rayBasePoint,
        Vector3d rayDir,
        double rayRadius,
        out SubentityId[] subEntIds,
        out DoubleCollection parameters
)

Parameters

rayBasePoint  Point3d
[in] Base point to start a ray from.
rayDir  Vector3d
[in] Ray direction.
rayRadius  Double
[in] Ray radius, which defines the tolerance used for intersection checking.
subEntIds  SubentityId
[out] Receives an array of subentities. It can contain one of the following: faces, edges or vertices.
parameters  DoubleCollection
[out] Receives an array of parameters. Parameters show the intersection between a ray and subentities.
Remarks
This method is implemented only for the Spatial modeler.
See Also

©  Bricsys NV. All rights reserved.