CircularArc2dIntersectWith(LinearEntity2d,
Tolerance) Method
|
Retrieves the intersection points between this
circular arc and the passed line according to the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point2d[] IntersectWith(
LinearEntity2d line,
Tolerance tolerance
)
Public Function IntersectWith (
line As LinearEntity2d,
tolerance As Tolerance
) As Point2d()
public:
array<Point2d>^ IntersectWith(
LinearEntity2d^ line,
Tolerance tolerance
)
member IntersectWith :
line : LinearEntity2d *
tolerance : Tolerance -> Point2d[]
Parameters
- line LinearEntity2d
- [in] A 2D line to intersect with.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point2d
Array of intersection points.
See Also