CurveCreateFromGeCurve(Curve3d, Vector3d, Tolerance) Method

Creates a curve that is identical to the specified OdGeCurve3d curve (wrapped by the Curve3d class) and lies on a plane with a normal vector perpendicular to the plane.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static Curve CreateFromGeCurve(
        Curve3d geCurve,
        Vector3d vec,
        Tolerance tolerance
)

Parameters

geCurve  Curve3d
[in] OdGe curve from which to create this curve.
vec  Vector3d
[in] Normal to the plane where the curve lies.
tolerance  Tolerance
[in] Geometric tolerance.

Return Value

Curve
See Also

©  Bricsys NV. All rights reserved.