DisplayStyle Class

This class wraps the OdGiDisplayStyle class which defines a set of display properties that can be applied to graphical entities. For more information, see Working with Visual Styles.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDisplayStyle

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DisplayStyle : RXObject, 
        ICloneable

The DisplayStyle type exposes the following members.

Constructors
  Name Description
Public method DisplayStyle Default constructor for the DisplayStyle class.
Top
Properties
  Name Description
Public property Brightness Property that represents the brightness for this display style.
Public property DisplaySettings Property that represents the display settings for this display style.
Public property ShadowType Property that represents the shadow type for this display style.
Top
Methods
  Name Description
Public method Clone Clones the current display styles and returns a handle to the cloned object.
Public method Set Sets the display styles from the passed DisplayStyle object.
Top
See Also

©  Bricsys NV. All rights reserved.