EntityMoveGripPointsAt(GripDataCollection,
Vector3d, MoveGripPointsFlags)
Method
|
Applies a vector offset to one or more grip
points.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void MoveGripPointsAt(
GripDataCollection appData,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
Public Overridable Sub MoveGripPointsAt (
appData As GripDataCollection,
offset As Vector3d,
bitFlags As MoveGripPointsFlags
)
public:
virtual void MoveGripPointsAt(
GripDataCollection^ appData,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
abstract MoveGripPointsAt :
appData : GripDataCollection *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
override MoveGripPointsAt :
appData : GripDataCollection *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
Parameters
- appData GripDataCollection
- [in] Collection of grip points to move. The items in the
collection must have associated application data representing
grips.
- offset Vector3d
- [in] The vector (in WCS coordinates) indicating the direction
and magnitude of the translation.
- bitFlags MoveGripPointsFlags
- [in] The bitmap of one or more flags specified by the
MoveGripPointsFlags enumeration.
See Also