CustomScale Structure

This class stores the numerator and denominator values that compose a custom print scale.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesCustomScale

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct CustomScale

The CustomScale type exposes the following members.

Constructors
  Name Description
Public method CustomScale Constructor for the CustomScale class. Creates a custom print scale with the passed numerator and denominator values.
Top
Properties
  Name Description
Public property Denominator Property that represents a denominator of this custom scale.
Public property Numerator Property that represents a numerator of this custom scale.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(CustomScale) Checks whether the passed object is equal to this object.
Public method IsEqualTo(CustomScale, Tolerance) Checks whether the passed object is equal to this object according to the specified tolerance.
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(CustomScale, CustomScale) Equality operator for the CustomScale class. Checks whether objects are equal.
Public operatorStatic member Inequality(CustomScale, CustomScale) Inequality operator for the CustomScale class. Checks whether objects are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.