QuadSelectionData Class

This class encapsulates the preselected, hovered, or otherwise dynamic selection, usually from user selection of any kind; the AcSelection class allows to modify the dynamic selection.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.QuadQuadSelectionData

Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class QuadSelectionData : DisposableWrapper

The QuadSelectionData type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Public method boundaryAt returns the complete selection as array of AcDbFullSubentPath, at given index
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method entityAt returns the entity in selection, at given index
Public method hasTypes returns a combination of 'SelectedType' values, indicating the types of contained entities, subentities and boundaries.
Public method isValid Returns 'true' if this AcSelectionData is valid; returns 'false' for an empty object
Public method length returns the number of contained entities, subentities and boundaries
Public method selectionSet returns the complete selection as array of AcDbFullSubentPath, at given index
Public method subentAt returns the full entity path in selection, at given index
Public method typeAt returns the type of entity in selection, at given index
Top
See Also

©  Bricsys NV. All rights reserved.