GripOverruleGetGripPoints(Entity,
GripDataCollection, Double, Int32,
Vector3d, GetGripPointsFlags)
Method
|
Overrules the OdDbEntity::subGetGripPoints()
C++ method and calls it in the default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void GetGripPoints(
Entity entity,
GripDataCollection grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
Public Overridable Sub GetGripPoints (
entity As Entity,
grips As GripDataCollection,
curViewUnitSize As Double,
gripSize As Integer,
curViewDir As Vector3d,
bitFlags As GetGripPointsFlags
)
public:
virtual void GetGripPoints(
Entity^ entity,
GripDataCollection^ grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
abstract GetGripPoints :
entity : Entity *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> unit
override GetGripPoints :
entity : Entity *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> unit
Parameters
- entity Entity
- [in] Entity that this overrule applies to.
- grips GripDataCollection
- [in] A collection of grip data objects.
- curViewUnitSize Double
- [in] Size of one drawing unit in the current viewport (in
pixels).
- gripSize Int32
- [in] Size of the current grip point (in pixels).
- curViewDir Vector3d
- [in] A vector that specifies the view direction in the current
viewport.
- bitFlags GetGripPointsFlags
- [in] Mask of one or more flags specified by the
GetGripPointsFlags enumeration.
See Also