UnderlayItem Class

This interface is implemented by host applications for support of underlays. This interface is used by the UnderlayDefinition and UnderlayReference objects to work correctly.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesUnderlayItem
        Teigha.DatabaseServicesDgnUnderlayItem

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class UnderlayItem : DisposableWrapper

The UnderlayItem type exposes the following members.

Properties
  Name Description
Public property Extents Property that represents the the item's extents in item-model coordinates.
Public property Name Property that represents the unique name for the item within the file.
Public property Thumbnail Property that represents the preview image of the item.
Public property Units Property that represents the units used by the item.
Public property UsingPartialContent Property that indicates whether the item is using only part of all the content of the sheet/model represented by the item.
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.