PointRef Class

This class defines a point reference between a dimension and its corresponding object.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesPointRef
          Teigha.DatabaseServicesOsnapPointRef

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class PointRef : RXObject

The PointRef type exposes the following members.

Constructors
  Name Description
Protected method PointRef Initializes a new instance of the PointRef class
Protected method PointRef(IntPtr, Boolean) Initializes a new instance of the PointRef class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method EvalPoint  
Public method GetEntities  
Public method IsGeomErased  
Public method IsXrefObj  
Public methodStatic member MswcsToPswcs  
Public method UpdateDueToMirror  
Public method UpdateSubentPath  
Public method UpdateXrefSubentPath  
Top
See Also

©  Bricsys NV. All rights reserved.