OsnapPointRef Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesPointRef
          Teigha.DatabaseServicesOsnapPointRef

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class OsnapPointRef : PointRef

The OsnapPointRef type exposes the following members.

Constructors
  Name Description
Public method OsnapPointRef Initializes a new instance of the OsnapPointRef class
Protected method OsnapPointRef(IntPtr, Boolean) Initializes a new instance of the OsnapPointRef class
Top
Properties
Methods
  Name Description
Public method EvalPoint
(Overrides PointRefEvalPoint)
Public method GetEntities
(Overrides PointRefGetEntities(Boolean))
Public method IntersectEntity  
Public method IsGeomErased
(Overrides PointRefIsGeomErased)
Public method IsXrefObj
(Overrides PointRefIsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean))
Public method MainEntity  
Public method UpdateDueToMirror
(Overrides PointRefUpdateDueToMirror(Boolean))
Public method UpdateSubentPath
(Overrides PointRefUpdateSubentPath(IdMapping))
Public method UpdateXrefSubentPath
(Overrides PointRefUpdateXrefSubentPath)
Top
See Also

©  Bricsys NV. All rights reserved.