EntityGetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) Method

Returns all appropriate object snap points of this entity.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void GetObjectSnapPoints(
        ObjectSnapModes snapMode,
        int gsSelectionMark,
        Point3d pickPoint,
        Point3d lastPoint,
        Matrix3d viewTransform,
        Point3dCollection snapPoints,
        IntegerCollection geometryIds,
        Matrix3d insertionMat
)

Parameters

snapMode  ObjectSnapModes
[in] The object snap mode being queried.
gsSelectionMark  Int32
[in] The GS marker of the subentity being queried.
pickPoint  Point3d
[in] Point (in WCS coordinates) picked during the object snap operation.
lastPoint  Point3d
[in] Point (in WCS coordinates) selected just before pickPoint.
viewTransform  Matrix3d
[in] The WCS->DCS transformation matrix.
snapPoints  Point3dCollection
[in/out] Receives an array of UCS object snap points. May contain elements before method execution; new elements are appended to the end of the collection.
geometryIds  IntegerCollection
[out] Reserved for future use.
insertionMat  Matrix3d
[in] Block transformation matrix. Entities contained in a block have the block transformation according to this parameter.

Return Value

true if this method is implemented, false otherwise.
Remarks
snapMode must be one of the following: Name Value Description ModeEnd 1 Endpoint ModeMid 2 Midpoint ModeCen 3 Center ModeNode 4 Node ModeQuad 5 Quadrant ModeIntersec 6 Intersection ModeIns 7 Insertion point ModePerp 8 Perpendicular ModeTan 9 Tangent ModeNear 10 Nearest ModeApint 11 Apparent intersection ModePar 12 Parallel ModeStart 13 Unknown
See Also

©  Bricsys NV. All rights reserved.