SubentityOverruleGetSubentPathsAtGsMarker
Method
|
Overrules the
Entity.subGetSubentPathsAtGsMarker() method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual FullSubentityPath[] GetSubentPathsAtGsMarker(
Entity entity,
SubentityType t,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewXform,
ObjectId[] entAndInsertStack
)
Public Overridable Function GetSubentPathsAtGsMarker (
entity As Entity,
t As SubentityType,
gsMark As IntPtr,
pickPoint As Point3d,
viewXform As Matrix3d,
entAndInsertStack As ObjectId()
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetSubentPathsAtGsMarker(
Entity^ entity,
SubentityType t,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewXform,
array<ObjectId>^ entAndInsertStack
)
abstract GetSubentPathsAtGsMarker :
entity : Entity *
t : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewXform : Matrix3d *
entAndInsertStack : ObjectId[] -> FullSubentityPath[]
override GetSubentPathsAtGsMarker :
entity : Entity *
t : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewXform : Matrix3d *
entAndInsertStack : ObjectId[] -> FullSubentityPath[]
Parameters
- entity Entity
- [in] Entity.
- t SubentityType
- [in] Subentity type.
- gsMark IntPtr
- [in] GS marker representing a specific subentity.
- pickPoint Point3d
- [in] WCS coordinates of the point picked during the selection
of the entity.
- viewXform Matrix3d
- [in] A transformation matrix to transform from WCS to DCS.
- entAndInsertStack ObjectId
- [in] Array of object IDs that are the nested containers of the
subentity.
Return Value
FullSubentityPath
Array of full subentity path objects identifying the subentities
generated from the GS marker.
See Also