DatabaseWblockCloneObjects Method
|
Uses the deep cloning mechanism to write
specified objects of this database to the new database. The objects
can be taken from different source databases and must match the
type of owner specified.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void WblockCloneObjects(
ObjectIdCollection identifiers,
ObjectId id,
IdMapping mapping,
DuplicateRecordCloning cloning,
bool deferTranslation
)
Public Sub WblockCloneObjects (
identifiers As ObjectIdCollection,
id As ObjectId,
mapping As IdMapping,
cloning As DuplicateRecordCloning,
deferTranslation As Boolean
)
public:
void WblockCloneObjects(
ObjectIdCollection^ identifiers,
ObjectId id,
IdMapping^ mapping,
DuplicateRecordCloning cloning,
bool deferTranslation
)
member WblockCloneObjects :
identifiers : ObjectIdCollection *
id : ObjectId *
mapping : IdMapping *
cloning : DuplicateRecordCloning *
deferTranslation : bool -> unit
Parameters
- identifiers ObjectIdCollection
- [in] Collection of object identifiers for which deep cloning
should be performed.
- id ObjectId
- [in] Object ID of the object to be the owner of the
clones.
- mapping IdMapping
- [in] Collection of objects to be used for mapping input object
identifiers relationships.
- cloning DuplicateRecordCloning
- [in] Duplication record cloning options.
- deferTranslation Boolean
- [in] Flag that specifies whether identifier translation should
be performed.
Remarks
The
id parameter must have one of the following types:
BlockTableRecord, Dictionary, or SymbolTable. The
cloning parameter specifies what happens if symbols
or dictionaries are cloned while duplicates are found in the
destination database.
cloning must be the
same if used in multiple calls and can be one of the following:
Mode |
Description |
Ignore |
If a duplicate is found, ignore the clone and continue to use
the existing record in the destination database. This is how the
INSERT command and Database.insert() operate. |
Replace |
If a duplicate is found, replace it with the cloned
record. |
MangleName |
Alter all the incoming record names. Altering also ensures
unique names. This is how the RefEdit command works. |
UnmangleName |
Primarily used by RefEdit when it checks the records back into
the origin database. Any altering done by kDrcMangleName is undone,
and then it defaults to Ignore. In other words, if a duplicate is
found after removing the alterations, the existing record is still
used and the cloned one is ignored. |
See Also