FieldEngineEvaluateFields Method
|
Evaluates fields in the specified
database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static FieldUpdateResult EvaluateFields(
Database pDb,
int nContext,
ObjectIdCollection objIds,
ObjectIdCollection pFieldsToEvaluate,
string pszEvaluatorId,
EvalFields nEvalFlag
)
Public Shared Function EvaluateFields (
pDb As Database,
nContext As Integer,
objIds As ObjectIdCollection,
pFieldsToEvaluate As ObjectIdCollection,
pszEvaluatorId As String,
nEvalFlag As EvalFields
) As FieldUpdateResult
public:
static FieldUpdateResult EvaluateFields(
Database^ pDb,
int nContext,
ObjectIdCollection^ objIds,
ObjectIdCollection^ pFieldsToEvaluate,
String^ pszEvaluatorId,
EvalFields nEvalFlag
)
static member EvaluateFields :
pDb : Database *
nContext : int *
objIds : ObjectIdCollection *
pFieldsToEvaluate : ObjectIdCollection *
pszEvaluatorId : string *
nEvalFlag : EvalFields -> FieldUpdateResult
Parameters
- pDb Database
- [in] Database for which fields are evaluated.
- nContext Int32
- [in] Context in which the field is evaluated.
- objIds ObjectIdCollection
- [in] Array of object IDs of objects whose fields are
evaluated.
- pFieldsToEvaluate ObjectIdCollection
- [in] Array of object IDs of fields to be evaluated.
- pszEvaluatorId String
- [in] Evaluator identifier.
- nEvalFlag EvalFields
- [in] One or more EvalFields option
flags.
Return Value
FieldUpdateResult
An object that stores information about how many fields are found
during evaluation and how many are evaluated.
Remarks
The nContext parameter can be a predefined FieldEvaluationOptions enum flag or a user-defined
context flag; this context flag is passed to the evaluator. If
objIds has non-null identifiers, fields
are evaluated for these objects (that correspond to non-null
identifiers). If pFieldsToEvaluate has
non-null identifiers, the fields in the specified objects are
evaluated. If this parameter is null, all the fields in the
specified objects are evaluated. If pszEvaluatorId is a non-null string, the fields
matching this evaluator ID are evaluated. If this parameter is
null, all the fields in the specified objects are evaluated.
See Also