FieldEngine Class

This class manages the evaluation of fields.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesFieldEngine

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class FieldEngine : RXObject

The FieldEngine type exposes the following members.

Properties
  Name Description
Public property EvaluatorLoaderCount Returns the number of registered field evaluator loaders.
Public propertyStatic member Global Returns a global one-per-session field engine.
Top
Methods
  Name Description
Public methodStatic member EvaluateFields Evaluates fields in the specified database.
Public method FindEvaluator Returns an evaluator for the specified field from the set of registered evaluators if the field does not have an evaluator ID.
Public method GetEvaluator Returns the field evaluator for the specified evaluator ID.
Public method GetEvaluatorLoader Returns the field evaluator loader at the specified index.
Public method RegisterEvaluatorLoader Registers the evaluator loader with the engine.
Public method UnregisterEvaluatorLoader Unregisters the evaluator loader from the engine.
Top
Remarks
The field engine is a global one-per-session object. The field evaluators should register their loader with the engine during application startup.
See Also

©  Bricsys NV. All rights reserved.